Microsoft (MSN) Messenger not working on Mac

Getting this when trying to sign in to Messenger: "Sign in to Microsoft Messenger failed because the service is not responding."

Delete:  userLibraryPreferencesMicrosoftMicrosoft Messenger User Cache.plist

Random Posts in WordPress

Okay, there are plenty of places online with instructions on randomizing posts in WordPress; even WordPress tells how. But here's my version along with the code I used.

Basically, I randomized the loop, and this required replacing the standard loop like this:

Replace…

::CODECOLORER_BLOCK_1::

with…

::CODECOLORER_BLOCK_2::

That worked for me. (note: setup_postdata() prepares the $post array as if it had been part of a standard loop, and the code did not work without it)

Curly quotes and WordPress permalinks don't mix

Curly QuotesSometimes curly quotes get copied and pasted into the title of our blog and WordPress just can't handle it. The problem lies in the permalinks and manually editing the permalink to get rid of curly quotes fixes it (but what a pain). In my search for an automated solution I discovered no hooks into this aspect of WordPress and, therefore, no plugins that handle it.

The solution involves editing WordPress code. I'm not a fan of this and I wish there were another way, but if there is, I haven't found it.

This solution I discovered in a conversation that ericr23 had with himself.

Add this to sanitize_title_with_dashes in wp-include/formatting.php:

::CODECOLORER_BLOCK_3::

Permalinks sanitized! And we could all do with a little more sanitation, right? We could do with some more sanity too!

Clean install and activation with Windows 7 Upgrade key

Don't you hate it when you replace a hard drive, install a perfectly legal copy of Windows 7 Upgrade and then try to activate it and it says it can't be activated because it is a clean install?  Here's a fix that worked for me:

  • Make sure there are no pending updates
  • Change HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionSetupOOBE ¬†MediaBootInstall from 1 to 0
  • In an elevated administrator command prompt type slmgr -rearm
  • Reboot
  • Run Activate Windows and use your key!

Found it here. Thanks mydigitallife.info!

Ubuntu to Ubuntu – Replacing a web server


So, the old web server is acting slow and I don't know why. Solution? Move to a new webserver, and upgrade to the latest OS along the way. It needs to be upgraded anyway, right?!

That's what I just did and here are the most valuable command line arguments for doing so:

[RAW]tar -pcvzf www.tar.gz www/
mysqldump -u root -pPassword --all-databases > alldata.sql

tar -pxvzf www.tar.gz
mysql -u root -pPassword &lt; alldata.sql[/RAW]<!--formatted-->

Of course, those commands are not all that I needed to do, but they are the ones that I will want in the future when I move to another web server. So, I guess you could say they're more like a personal note on how to transfer a directory without losing permissions and how to move an entire MySQL install.

The trick to syncing multiple Google calendars on iPad


You have to specify which calendars to sync in Google; go here…

https://www.google.com/calendar/iphoneselect

I you want to know more, iPad Candy has a full walkthrough on using multiple Google calendars on i-devices.

Hard reboot for iPad

My iPad froze today. It looked like it was just asleep, but it didn't respond when I hit the home button. Holding the hold/power button (which is how you do a normal reboot) didn't do anything either. It was stuck good. Here's the trick I used to fix it:

Hold both the home button and the hold/power button for a few seconds.

After doing that the silver apple appeared on the screen. When I hit the hold/power button again it booted up.

I'm not sure what caused it to freeze, but, the Apple device didn't display an error message. Just like their ads say, Macs don't get error messages. No, neither do iPads, apparently. They just go black. Not even a blue-screen-of-death or anything.

Thanks, Apple.

How to find an email recipient in Active Directory

Ugh! Active Directory crap!

1. Open Active Directory Users and Computers
2. Right Click on your domain and choose "Find…"
3. On the advanced tab choose the field User > Proxy Addresses
4. Condition is "Starts with"
5. Value is "SMTP:the_beginning_of_the_email_address"
6. Click Add
7. Click Find Now

Too hard. Too abstract. Why do you hate us, Microsoft? Why can't we just search for it and find it by right clicking?
Thanks to Exchangepedia for inspiring this solution.

If you want to use Sendmail, install it, dummy!

Right…I must have forgotten to install sendmail, because mail wasn't working for WordPress. First, to verify that sendmail wasn't working I ran this PHP script (thanks to phpeasystep.com)

&lt;?
// send e-mail to ...
$to=&quot;me@localhost&quot;;

// Your subject
$subject=&quot;Test&quot;;

// From
$header=&quot;from: your name &lt;your email&gt;&quot;;

// Your message
$message=&quot;Hello rn&quot;;
$message.=&quot;This is testrn&quot;;
$message.=&quot;Test again &quot;;

// send email
$sentmail = mail($to,$subject,$message,$header);

// if your email succesfully sent
if($sentmail){
echo &quot;Email Has Been Sent .&quot;;
}
else {
echo &quot;Cannot Send Email &quot;;
}

?&gt;<!--formatted-->

That confirmed it. And the fix was easy:

apt-get install sendmail

Doing this exposed a flaw in my hosts file and ZYXware.com had the answer

sudo gedit /etc/hosts

127.0.0.1 localhost.localdomain localhost
127.0.1.1 zyxware01.localdomain zyxware01

If you have a static IP you can replace 127.0.1.1 with your static IP.

So, now mail works from php and, more importantly, WordPress.

[EDIT]
Sheesh…Ubuntu is picky. Here's (almost) exactly what I have for the top half of my hosts file

127.0.0.1    myhostname    localhost.localdomain    localhost
::1    myhostname    localhost6.localdomain6    localhost6
127.0.1.1    myhostname
192.168.1.100    myhostname.mydomain.com

The spaces are actually tabs, I don't know if it matters.

I also don't know what is needed and what is not, but I mimicked this layout on a new server and it worked; the MTA blah-blah service no longer takes forever and sendmail works nice and quickly.
[/EDIT]

Call Manager Conference Calls Dropping

Ok, we have a Cisco Call Manager system for our IP phones and when we used them to make a conference call a weird thing would happen – someone at random would get dropped from the conference after about a minute.

Rebooting the server did not help but reseting the conference bridge did the trick.

Service -> Media Resource -> Conference Bridge -> Reset Selected